Promash Problems On Win 7

Australia & New Zealand Homebrewing Forum

Help Support Australia & New Zealand Homebrewing Forum:

Tony

Quality over Quantity
Joined
26/4/04
Messages
7,168
Reaction score
276
A couple years ago i upgraded my old XP lappy to a new one with Win 7. I remember having issues with Windows 7 no longer supporting the XP style help pages, but a windows hotfix sorted this out. Functionality was never as good as on XP, but it worked!

Now I'm upgrading to a new laptop again, with windows 7 on it, and i have a little problem :(

It seems when i copy the Promash folder onto a usb drive from the Win 7 computer, and paste it onto the new Win 7 computer, non of the newly created files or file edits copy across. Its just as it was when i copied it off the XP computer.

very pissed off!

I have notices when i create a new recipe or brew session file on windows 7, it puts a little padlock on the file ?????

i have no idea what this is?



Its like all the new stuff i have put in Promash over the last couple years is stored somewhere else. When i check the properties on the files they are in the Promash folder, but when i copy and past them somewhere else, they cont copy across, and any modified recipe folders copy across as they were when i copied them from the XP computer.

Anyone with any ideas on how i can save all my brewing history for the last 2 years?

And........... I'm not getting any pet penguins on my computer!
 

wombil

Well-Known Member
Joined
20/2/11
Messages
507
Reaction score
45
Tony,
personnaly I'd stick with XP,the best windows os of all in my opinion.
The new 7 does not seem to be reading the previous 7 files but I can't help with a solution now.
I have had a lot of good help and advice from" PC Guide Discussion forums" and if you don't get the problem resolved here,and I know there are a lot of smart PC people on here, I would try there.
Good luck with it,
wombil.
Just seen your file extension .brw maybe change that to .doc or .txt or something that win 7 can read.?
clutching,I know, but.
 

GuyQLD

Well-Known Member
Joined
13/5/12
Messages
504
Reaction score
152
I'm going to go out on a limb here and assume you had it in either a My Documents folder or some other profile related folder (file pathway under /users/).

If you go from one win 7 session to another even if you've made an account with the same name it will identify the permissions as belonging to a different account, that padlock means it doesn't belong to you.

You might be able to change the file permissions for that folder with an admin account, I had this problem a while ago after I formatted (I remap my documents to another drive so that formatting doesn't touch user profiles... but I discovered that in win 7 this problem occurs.) Pretty sure I fixed it by creating a separation admin account and moving stuff all over the place before changing back.

You might have to look on msdn for more hints.
 

Tony

Quality over Quantity
Joined
26/4/04
Messages
7,168
Reaction score
276
Tony,
personnaly I'd stick with XP,the best windows os of all in my opinion.

Just seen your file extension .brw maybe change that to .doc or .txt or something that win 7 can read.?
clutching,I know, but.
+1 on being the best. I am geting to know and like windows 7 a lot beter now days but XP was just sooooo user friendly!

As for file names..... The file names are the same as the ones created in XP..... and it see's them. Id say its got to do with permissions as GuyQLD said, but i can see where :(


I'm going to go out on a limb here and assume you had it in either a My Documents folder or some other profile related folder (file pathway under /users/).

If you go from one win 7 session to another even if you've made an account with the same name it will identify the permissions as belonging to a different account, that padlock means it doesn't belong to you.

You might be able to change the file permissions for that folder with an admin account, I had this problem a while ago after I formatted (I remap my documents to another drive so that formatting doesn't touch user profiles... but I discovered that in win 7 this problem occurs.) Pretty sure I fixed it by creating a separation admin account and moving stuff all over the place before changing back.

You might have to look on msdn for more hints.
The promash folder is under C:\Program files\Promash

I saved it there with all the other programs for the sake of keeping things together.

I had a look at the permissions but not sure what to change.

there are different permissions for creator, administrater, user, hitler, you name it........ Ahhhhhh the reason people look for alternatives to windows hey!
 

Tony

Quality over Quantity
Joined
26/4/04
Messages
7,168
Reaction score
276
Mmmmm

When i open the brew sessions area in Promash, it sees the files i have created in windows 7 but with the lock on them.

But when i search in the sessions folder on C:\ they arnt there.

but when i right click the file in promash and click properties, it points to the c:\ folder I'm looking in.

Its like Windows 7 doesn't recognize the promash files created or changes made in promash under Windows 7, but it can see the stuff from XP.

But it open the files on the local computer they are created or modified on.

Ahhhhhh im thinking im finally going to have to try beersmith.

Is it Win 7 ready?
 

Ducatiboy stu

Well-Known Member
Joined
2/4/05
Messages
14,269
Reaction score
3,832
Shall not laugh at the fact that Promash works great on Linux :lol:
 

Tony

Quality over Quantity
Joined
26/4/04
Messages
7,168
Reaction score
276
Stu i remember asking you if it would work and you said.... probably not, you may need to run wine ???
 

pk.sax

RIP bum
Joined
19/8/10
Messages
4,362
Reaction score
415
I think I found your problem.

The files are made by Promash running with restricted permissions.

Ok, here is what to do on the new computer, right click on the shortcut, properties, compatibility.

If run as administrator is checked, uncheck it. Or vice versa.

Open Promash and try to open the files again. Should work. I'll have to figure out how to switch their permission levels around.
 

pk.sax

RIP bum
Joined
19/8/10
Messages
4,362
Reaction score
415
OK, maybe a more permanent solution:

Look in Old computer C:\Users\<Your User Name>\AppData\Local\VirtualStore\Program Files\ProMash\recipes

There should be your "protected" promash recipes. Corresponding folders in that location for brew sessions etc.

Copy these into the new computer at this place:

C:\Program Files\ProMash\recipes (and other corresponding folders...)

Now, promash on the new computer should pick up all those files even when being run as administrator.

I hate UAC
 

keifer33

Well-Known Member
Joined
22/3/09
Messages
1,501
Reaction score
110
You may need to take ownership of the files.

This was taken from another source but should work.

Microsoft said:
You may try the below steps and check but make sure you have logged in as administrator of the computer:

1. Take ownership of the folder
i. Right-click the file or folder, click Properties, and then click the Security tab.
ii. Click Advanced, and then click the Owner tab.
iii. Click Edit, and then do one of the following:
iv. To change the owner to a user or group that is not listed, click Other users and groups and, in Enter the object name to select (examples), type the name of the user or group, and then click OK.
v. To change the owner to a user or group that is listed, in the Change owner to box, click the new owner.
vi. If you want to take ownership of the contents of the folder, select the Replace owner on subcontainers and objects check box.
vii. Click OK, and then click Yes when you receive the following message: You do not have permission to read the contents of directory folder name. Do you want to replace the directory permissions with permissions granting you Full Control?
viii. All permissions will be replaced if you click Yes.
ix. Click OK, and then reapply the permissions and security settings that you want for the folder and its contents.
Below link for reference: http://windows.microsoft.com/en-us/windows...iles-or-folders

2. Give full permission to the folder. Steps to follow
i. Right click on the Folder select Properties
ii. Select Security tab
iii. Choose Edit button(if prompted to click continue, please click on continue)
iv. Select Add type in ‘Everyone’ (without quotes)
v. Click on Check names
vi. Click Ok
vii. Under Group or user name select Everyone
viii. Under Permissions for system check Allow full control.
Below link will help you learn more about it: Files and Folder Permission:
http://windowshelp.microsoft.com/Windows/e...571e9d1033.mspx
 

fraser_john

Go Pies
Joined
17/1/06
Messages
2,477
Reaction score
374
Location
Victoria
Shall not laugh at the fact that Promash works great on Linux :lol:
:icon_offtopic:

Stu, not 100% correct, at least not on my two Ubuntu installs. 99% of the time, no issue, but occassionally, the button area of a Promash window won't redraw properly after restoring from being minimized and you cannot see where the buttons are!

Only problem I have found with Promash under Ubuntu.
 

Ducatiboy stu

Well-Known Member
Joined
2/4/05
Messages
14,269
Reaction score
3,832
:icon_offtopic:

Stu, not 100% correct, at least not on my two Ubuntu installs. 99% of the time, no issue, but occassionally, the button area of a Promash window won't redraw properly after restoring from being minimized and you cannot see where the buttons are!

Only problem I have found with Promash under Ubuntu.

Mmmmm..havent found that issue yet...

And yes Tony...I did need wine, but any M$ programe needs wine...
 

Tony

Quality over Quantity
Joined
26/4/04
Messages
7,168
Reaction score
276
OK, maybe a more permanent solution:

Look in Old computer C:\Users\<Your User Name>\AppData\Local\VirtualStore\Program Files\ProMash\recipes

There should be your "protected" promash recipes. Corresponding folders in that location for brew sessions etc.

Copy these into the new computer at this place:

C:\Program Files\ProMash\recipes (and other corresponding folders...)

Now, promash on the new computer should pick up all those files even when being run as administrator.

I hate UAC
Mate........... thanks sooooooooooo much for this.

I had a play with it today and found all the files!

My folder options was set to hide hidden files and folders so i couldnt see the AppData folder :p

Will copy them all across later on to see how it goes.

Sigh............. i miss XP :(
 

Ducatiboy stu

Well-Known Member
Joined
2/4/05
Messages
14,269
Reaction score
3,832
You may try the below steps and check but make sure you have logged in as administrator of the computer:

1. Take ownership of the folder
i. Right-click the file or folder, click Properties, and then click the Security tab.
ii. Click Advanced, and then click the Owner tab.
iii. Click Edit, and then do one of the following:
iv. To change the owner to a user or group that is not listed, click Other users and groups and, in Enter the object name to select (examples), type the name of the user or group, and then click OK.
v. To change the owner to a user or group that is listed, in the Change owner to box, click the new owner.
vi. If you want to take ownership of the contents of the folder, select the Replace owner on subcontainers and objects check box.
vii. Click OK, and then click Yes when you receive the following message: You do not have permission to read the contents of directory folder name. Do you want to replace the directory permissions with permissions granting you Full Control?
viii. All permissions will be replaced if you click Yes.
ix. Click OK, and then reapply the permissions and security settings that you want for the folder and its contents.
Below link for reference: http://windows.microsoft.com/en-us/windows...iles-or-folders

2. Give full permission to the folder. Steps to follow
i. Right click on the Folder select Properties
ii. Select Security tab
iii. Choose Edit button(if prompted to click continue, please click on continue)
iv. Select Add type in Everyone (without quotes)
v. Click on Check names
vi. Click Ok
vii. Under Group or user name select Everyone
viii. Under Permissions for system check Allow full control.
Below link will help you learn more about it: Files and Folder Permission:


Jeezuz.......... sudo anyone.......
 

Latest posts

Top