BrewPiLess version update

Australia & New Zealand Homebrewing Forum

Help Support Australia & New Zealand Homebrewing Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


New Member
Reaction score
Hello everyone,

I do apologise if this has been covered off somewhere but all the searching I have done has not returned any worthwhile results. Please feel free to point me to somewhere if it is available.

I am tearing my hair out trying to update the BPL version from 4.0 to the latest 4.2 and cannot get it to work regardless of how I go about it.

I have tried Arduino IDE, Node MCU, Visual Studio but nothing works for me.

Obviously I managed to do this when I first made the unit so clearly it does work just not for me now.

Does anyone have a simple to follow, up to date, step by step guide on how to do this. I have git hub desktop and also git gui so can d/l what I need if I am missing something.

Please let me say thank you in advance for any responses, advice or assistance.

Thank you for looking at this request for help but I have found I was being impatient. It turns out the "platform io" had not finished installing in Visual Studio and I once that did finish I was able to work with it to finish the update.

It does still need to be worked out whether any of the other options should still work but mine is updated so all is in goodness. :cool:
I use nodemcu flasher to drop the images on the arduino. You just have to flash the blank image first. Been a while since I flashed them, I am still on 4.0 but they are solid so no reason to try and break stuff!
I had fitted the oled 1306 and was using the diyhomebrewers software which gave some info on the screen rather than LCD.
Having flashed the esp3266 and the ispindel firmwares 4.2x neither display anything except white lines. Very strange. Is there a different wiring arrangement for the oled display?

Latest posts