Quantcast

Leaking 525s taps

Aussie Home Brewer

Help Support Aussie Home Brewer:

adz1179

Well-Known Member
Joined
20/12/10
Messages
290
Reaction score
7
i have just setup a second tap and having major leakage issues. its leaking from the shank. some pictures attached. its a perlick 525 flow control with short shanks from a site sponsor, as soon as i plug in the beer line, beer pours out where it connects to the shank. awesome.

i have two taps, both bought brand new, both shanks are brand new, both exactley the same. i have unscrewed both taps from the shanks and both look identical on the inside

photo 2.JPG

photo 1.JPG

photo 3.JPG

i have taken them apart and put them both back together 100 times now and its doing my head in.

anyone have any suggestions?
 

Amber Fluid

Beer Snob
Joined
3/1/11
Messages
1,379
Reaction score
49
I remember someone previously here also had the same issues and I believe they rang the place of purchase who ended up replacing them.
 

adz1179

Well-Known Member
Joined
20/12/10
Messages
290
Reaction score
7
Replaced the shank or tap or both?
 

Spiesy

Illmatic
Joined
28/12/11
Messages
3,274
Reaction score
1,124
Location
Melbourne
Am I correct in assuming that the leak is only on the new tap? If so, what happens when you swap the taps? This should tell you if the problem is with the tap or shank.
 

adz1179

Well-Known Member
Joined
20/12/10
Messages
290
Reaction score
7
Just tried swapping the taps. Same thing. I looks like the shank is the issue
 

adz1179

Well-Known Member
Joined
20/12/10
Messages
290
Reaction score
7
Bugger. Was going to give it a good work over this afternoon. Oh we'll, back she goes. Cheers for the replies.
 

beerdrinkingbob

milk is for babies......
Joined
9/7/10
Messages
1,097
Reaction score
35
adz1179 said:
Just tried swapping the taps. Same thing. I looks like the shank is the issue
has the rubber oring in the shanks got a split or maybe dropped out?
 

TidalPete

BREWING BY THE BEACH
Joined
2/8/04
Messages
5,182
Reaction score
480
Location
Sunshine Coast, Queensland
Spiesy said:
Indeed. May be a dodgy seal in there, mate.
If they're 'o' rings like on the 575's then a trip to Pirtek or similar place will yield a suitable replacement. Take the tap with you.
Perhaps check the ends of the shanks for burrs or unevenness first?
 

Latest posts

Top