Quantcast

Regulator Problems

Aussie Home Brewer

Help Support Aussie Home Brewer:

aspro

Well-Known Member
Joined
14/8/05
Messages
83
Reaction score
3
g day
Ive been using my c i g reg for 2 years from new and had no probs until today I came home from work and turned on my reg witch is usualy set at 60 kpa for pouring I poured myself a beer and left the c02 on when I came back for my second beer the gauge was at 600 kpa so I turned it off and released the presure I then turned the reg down to nothing and turned the bottle back on and it went back up to 600kpa no mater what i do it keeps going up to 600kpa please help :blink:
 

Batz

Batz Brewery...Hand crafted beers from the 'Batcav
Joined
8/8/03
Messages
12,728
Reaction score
1,415
aspro said:
g day
Ive been using my c i g reg for 2 years from new and had no probs until today I came home from work and turned on my reg witch is usualy set at 60 kpa for pouring I poured myself a beer and left the c02 on when I came back for my second beer the gauge was at 600 kpa so I turned it off and released the presure I then turned the reg down to nothing and turned the bottle back on and it went back up to 600kpa no mater what i do it keeps going up to 600kpa please help :blink:
[post="75264"][/post]​

There it really little that can go wrong with a reg. there simple as.
Pull it apart , the pin behind the diaphram must be sticking.
This happens if a little beer has got into it , just clean it up and a very light lube and it will be OK.
check the diaphram has no holes or rips in it.

Batz
 

Latest posts

Top