Keg King MKII temp controller issues

Australia & New Zealand Homebrewing Forum

Help Support Australia & New Zealand Homebrewing Forum:

Beerdave

Member
Joined
8/2/17
Messages
5
Reaction score
0
Hi. Recently purchased a keg King MKII temp controller. On heating function (I'm using a rims system), the temp is dropping below set points before the heating relay kicks in. E.g. At set point of 65 degrees (hysteresis configured to 0.1 degree), temp can drop to 62 degrees. Wondering if others have experienced similar issues? Appreciate any help. Cheers, Dave.
 

osprey brewday

Well-Known Member
Joined
6/6/14
Messages
164
Reaction score
81
Location
port stephens
Check there is no delay/anti cycle timers set, not familiar with this controller but others have default 3 min delays. Indicator symbol may flash when its timing out.
 

mattyh77

Well-Known Member
Joined
16/12/16
Messages
172
Reaction score
45
Location
Seaforth, NSW
I don't have my manual handy, but there is definitely a delay setting you need to adjust. I have my cold setting set to 4 min so compressor wont burn out.
 

Beerdave

Member
Joined
8/2/17
Messages
5
Reaction score
0
osprey brewday said:
Check there is no delay/anti cycle timers set, not familiar with this controller but others have default 3 min delays. Indicator symbol may flash when its timing out.
thanks. There's no delay set but thanks for suggesting
 

Beerdave

Member
Joined
8/2/17
Messages
5
Reaction score
0
mattyh77 said:
I don't have my manual handy, but there is definitely a delay setting you need to adjust. I have my cold setting set to 4 min so compressor wont burn out.
thanks. Confirmed delays not thy the problem but thanks for the suggestion.
 

Latest posts

Top