Quantcast

Fermentation Problems with Coopers Brew A kit - help?

Aussie Home Brewer

Help Support Aussie Home Brewer:

BennyBrew

Member
Joined
24/6/19
Messages
12
Reaction score
1
Location
Adelaide, South Australia
After a year or so since my last home brew, I decided to ease my way back into the game with a kit brew.

I went for the Coopers Brew A can and mixed 1KG of dried light malt extract to make a 18L batch.
OG reading was 1028 which I thought was low but wasn't really sure what to expect of the kit.

After 24 hours after pitching yeast I didn't see any bubbling of the airlock or any noticeable signs of fermentation.

It has now been over 48 hours since pitching yeast and still no bubbling but some minor signs of fermentation (smell, ring of foam, etc.)
However, I have taken another hydrometer reading and it is still 1028? Am I in trouble here??

What should I do now? Any help would be appreciated. Cheers!
 

MHB

Well-Known Member
Joined
1/10/05
Messages
5,928
Reaction score
3,371
Location
Newcastle
Your problem is you didn't stir it enough. The OG would have been ~1.060 if you had.
I'd sterilise a spoon and give it a good mix.
Mark
 

BennyBrew

Member
Joined
24/6/19
Messages
12
Reaction score
1
Location
Adelaide, South Australia
Reckon you could be right. I thought it was a strange OG

I did try to splash it up a fair bit when adding the water to the 18L mark and swirled the fermenter around.
But probably was a bit under done on the stirring though.

So you would open the lid and mix it at this stage?
 

Latest posts

Top