Don't Wanna Bottle Too Early

Australia & New Zealand Homebrewing Forum

Help Support Australia & New Zealand Homebrewing Forum:

mrkitewhitey

Active Member
Joined
22/3/11
Messages
44
Reaction score
1
Howdy all,

Just a question about US-05. Last time I used it the same thing happened and in hindsight, I think it may have been stalled therefore throwing out consistent hydro readings... Umm, the beer has a layer of what looks like Cold break floating on the top... there is no activity and the temp has been kept at 16-18c for the past week. It is giving a consistent reading at 1.011. last time this happened I bottled but had a few gushers due to yeast probably waking up a little and chowing down on the priming sugar and getting a bit excited........

The layer of stuff..... Is this normal w US-05? For what it is worth I put another KnK batch down at the same time w TC Ale yeast and that one is as clear as a bell.....

By the way, they both TASTE amazing...... The US-05 one is Dr Smurto's Golden Ale.. YUMMO!

Thanks people... I hope I've been clear enough here.....

Cheers

Tony
 
Joined
11/12/10
Messages
728
Reaction score
84
Howdy all,

Just a question about US-05. Last time I used it the same thing happened and in hindsight, I think it may have been stalled therefore throwing out consistent hydro readings... Umm, the beer has a layer of what looks like Cold break floating on the top... there is no activity and the temp has been kept at 16-18c for the past week. It is giving a consistent reading at 1.011. last time this happened I bottled but had a few gushers due to yeast probably waking up a little and chowing down on the priming sugar and getting a bit excited........

The layer of stuff..... Is this normal w US-05? For what it is worth I put another KnK batch down at the same time w TC Ale yeast and that one is as clear as a bell.....

By the way, they both TASTE amazing...... The US-05 one is Dr Smurto's Golden Ale.. YUMMO!

Thanks people... I hope I've been clear enough here.....

Cheers

Tony
The AG recipe's FG is 1.012 if you have done the kit recipie word for word I would say you are done. I have never had a kit where I used only malt go under 1.010.
 

kelbygreen

Crazy Clown
Joined
28/11/09
Messages
2,850
Reaction score
21
I have found some batches of us05 (not all) stall and will kick back off again after a few days to a week I had many brews that stalled but more around the 1020 mark then a week later they woke up on there own and kept going again. Being 1.011 I would think it is very close to being done. I would still leave it 3 or so more days to be sure.
 

mrkitewhitey

Active Member
Joined
22/3/11
Messages
44
Reaction score
1
The AG recipe's FG is 1.012 if you have done the kit recipie word for word I would say you are done. I have never had a kit where I used only malt go under 1.010.

Thanks mate... I didn't even look at it that way.... Just spooked by my last effort w the US05... I appreciate the help

Tony
 
Top