Help Support Aussie Homebrewer by donating:

  1. We have implemented the ability to gift someone a Supporting Membership now! When you access the Upgrade page there is now a 'Gift' button. Once you click that you can enter a username to gift an account Upgrade to. Great way to help support this forum plus give some kudos to anyone who has helped you.
    Dismiss Notice
  2. Dismiss Notice

CraftBeerPi not starting on RPi

Discussion in 'Electronics, Hardware & Software' started by DanDanBeerMan, 4/10/19.

 

  1. DanDanBeerMan

    New Member

    Joined:
    4/10/19
    Messages:
    1
    Likes Received:
    0
    Gender:
    Male
    Location:
    UK
    Posted 4/10/19
    Hi all,

    I'm trying to get CraftBeerPi up and running. Installed everything ok. However, when it comes to starting the service, it just does nothing.

    pi@raspberrypi:~ $ sudo /etc/init.d/craftbeerpiboot start
    pi@raspberrypi:~ $ sudo /etc/init.d/craftbeerpiboot status
    pi@raspberrypi:~ $

    Can anyone help me get it up and running?

    Thanks

    Dan
     
  2. loco88

    Well-Known Member

    Joined:
    30/4/14
    Messages:
    91
    Likes Received:
    9
    Gender:
    Male
    Posted 9/10/19
    Happy to help as best I can, what OS are you running it on? Have you rebooted since install? Added it to autostart using the installer?
     
  3. Truman42

    Pro Pro

    Joined:
    31/7/11
    Messages:
    3,881
    Likes Received:
    564
    Gender:
    Male
    Home Page:
    Posted 10/10/19 at 2:46 AM
    This is an ongoing fault with CBPi V3. Wipe your SD card and start again but when it asks you if you want to install one wire support say no. Dont worry it will still be able to use one wire support. The CBpi facebook group has a lot of info about it.
    Also try this once youve installed it. .....then run cd craftbeerpi3
    sudo pip install -r requirements.txt

    restart your Raspberry PI
     
    Last edited: 10/10/19 at 3:09 AM

Share This Page